Loading

Topic: Problems pumping up deep rim tyres

Posted on: 1st Jun 2018 5:05 PM    Quote and Reply

Hi,

I am running dalkiia 60mil deep rim wheels on my bike, but have constant problems maintaing high pressure in the tyres. The wheels have valve extenders, which have been changed since I bought the wheels. No matter how much I leave the valves unscrewed within the valve extenders, I always have the same problem: even when the tyres feel a bit soft, it is impossible to pump air into them. The only solution to this that I have found is to deflate the tyres, which is sometimes difficult, then reinflate them. Sometimes, I have to remove the valve extenders to do this. I am pretty sure this is not a problem with the inner tubes, which are the same ones I was able to inflate without any problem before I got the deep rim wheels. Any advice?

Please help.

I didn't find the right solution from the Internet.

References:-
https://www.bikeradar.com/forums/viewtopic.php?t=12676584
Video content agency

Thanks!
Freshie Forumer
2 posts
Forum Rep: 0

Malaysia
Posted on: 2nd Jun 2018 10:59 AM    Quote and Reply


is your valves inside the extender or ontop of the extender?
there are quite a few shops that fix it the valves in the extender than your valve is open so that you could pump the air in.


 


I am using 60mm for rear too my extender i have the valve on the top so that the pump will be direct to the valve to pump in air.


 


Do what u deem is correct and be responsible on your own actions

Blog on My Cycling Journey including slimming down; https://thecyclingjourney.blogspot.sg

https://www.instagram.com/terencetan1978/?hl=en

Marketplace selling list: http://www.togoparts.com/marketplace/listings.php?range=5&lat=1.2945599446037&lng=103.8383102417&item=new-used&uname=terencetan1978&location=

Build on Fuji SL1.1: http://www.togoparts.com/forum/showthread.php?fid=29&tid=78278&loc=active&cb=showforum.php%3Ffid%3D29%26page_id%3D1&highlight=

Build on Sworks SL6 Tarmac: http://www.togoparts.com/forum/showthread.php?fid=29&tid=79128&page_id=-1#last
'Togo Admin'
181 posts
Forum Rep: 79


Riding:
Posted on: 2nd Jun 2018 10:59 AM    Quote and Reply


is your valves inside the extender or ontop of the extender?
there are quite a few shops that fix it the valves in the extender than your valve is open so that you could pump the air in.


 


I am using 60mm for rear too my extender i have the valve on the top so that the pump will be direct to the valve to pump in air.


 


Do what u deem is correct and be responsible on your own actions

Blog on My Cycling Journey including slimming down; https://thecyclingjourney.blogspot.sg

https://www.instagram.com/terencetan1978/?hl=en

Marketplace selling list: http://www.togoparts.com/marketplace/listings.php?range=5&lat=1.2945599446037&lng=103.8383102417&item=new-used&uname=terencetan1978&location=

Build on Fuji SL1.1: http://www.togoparts.com/forum/showthread.php?fid=29&tid=78278&loc=active&cb=showforum.php%3Ffid%3D29%26page_id%3D1&highlight=

Build on Sworks SL6 Tarmac: http://www.togoparts.com/forum/showthread.php?fid=29&tid=79128&page_id=-1#last
'Togo Admin'
181 posts
Forum Rep: 79


Riding:
Login to see your Forum Rankings